2

I am playing around with Salesforce visual workflow but getting an error 'The (DB_Add_Object) element in your flow has validation errors.'

I'm just trying to create an object based on a few fields on a screen element.

When I manually create the Object it works fine and there are no validation rules on the object.

I also added a test screen before load to make sure the fields are populated alright.

My question is how can I debug visual workflow? The debug log does not seem to have more detail on the error, am I missing something?

EDIT: From some more testing, it seems to be a managed package issue, something to do with the namespace I would assume. Has anyone tried using the Create Record function in a managed package on a custom object? It seems to work ok on standard objects.

  • 1
    Kris, I hope my answer helps you out! Just wondering if you might want to make the title of your question a bit more general? This will help others find out this information through future searches,e.g. How to handling / debug errors in Flow? – Andrew Fawcett Nov 2 '12 at 18:13
2

Take a look at Fault Connector Overview and $Flow.FaultMessage in the Flow documentation. This will allow you to route any faults (which get swallowed by default). You can see it in action here as well, we recently published an article on using this fantastic tool! enter image description here

| improve this answer | |
  • Thanks for that, it is good to know but the error I am getting is either not getting caught in the Fault or $Flow.FaultMessage = 'The (DB_Add_Object) element in your flow has validation errors.' – Kris Moyse Nov 2 '12 at 21:39
  • I have actually found after hours of testing that flow can not update a custom objects in an org with a managed package, can anyone confirm that? – Kris Moyse Nov 2 '12 at 21:42
  • That is strange, I'm pretty sure our developer that worked on the article I linked in my answered did so on a managed install of our objects. I'll give this ago for you. Also wondering if enabling the regular Debug Logs will shed more light on your issue... – Andrew Fawcett Nov 2 '12 at 22:27
  • Ok just given it ago with a simple Create element against a managed object and it worked fine. Can you attach some screenshots of what your doing and the error perhaps? – Andrew Fawcett Nov 2 '12 at 22:48
  • I am actually talking about an org that has a managed packed built in it. Not one that has had one installed. – Kris Moyse Nov 3 '12 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.