0

I am trying to create a Custom button on an Opp Record Page to trigger a flow.

I placed the flow Button on Campaign__c Record page. This Object, Campaign__c, has a Masterdetail relationship with Opps and a Lookup with Acc.

The flow is working correctly and if I debug it I get what I want: I start by selecting A record Opp. and the Lookup fields in the screen element get auto populated. this is where I select the Record enter image description here (Yeah, sorry for the OPP and ACC names)

When the flow is triggered from a record page I want the Account and Opp lookup fields to be auto-populated in the flow screen.

I honestly don't know how to get there, I have created record variable - Text or Record (tried both)

At the moment this is how is set up the 2 lookup fields in the flow and works (Only) within the debug page:

enter image description here enter image description here

I found a tip where it was suggesting to append a something to the button link: /flow/J_New_Campaign?OppRecordId={!Opportunity.Id}

Which I don't know if it makes sense.

Thank you all for the help and support.

2
  • 2
    Do you meant you want to create Campaign record from Opportunity page using Screenflow. Can you edit the post and let us know what you have tried so far Commented Mar 20, 2023 at 11:02
  • I tried to explain myself better. Please check out the updated version of my post. Commented Mar 21, 2023 at 10:09

1 Answer 1

0

I guess you are trying something like below to auto-populate Account and Opportunity on screen when we click a button on Opportunity Page.

enter image description here

I just created a variable as below

enter image description here

I have used that variable to populate the opportunity and Account details automatically as shown below.

enter image description here

enter image description here

I have added this screenflow as action and when I click button on opportunity it is working as expected

5
  • I did exactly the same, the only difference my flow is triggered from a button. if I had to guess the mistake is there;In the link! Also, if I debug and choose a random Opp. the 2 fields get prepopulated properly. when I press the button from a record page no "record-related" value is displayed. Commented Mar 21, 2023 at 11:18
  • Can you try it by creating an Action Commented Mar 21, 2023 at 11:26
  • I will try and let you know if worked, thanks!! Commented Mar 21, 2023 at 13:14
  • The error was a wrong reference to the var in the button Link. Is now working properly with button. Commented Mar 21, 2023 at 14:27
  • @JACOPOPARISI, Thanks for confirming. Commented Mar 21, 2023 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .