0

As soon as you combine reports from accounts, leads, cases, etc. in a single dashboard, the available fields with which you can create a filter are quickly reduced to just date fields.

Even when you create custom fields for these objects with the same name and type, they will not be offered as filter fields.

How to solve this?

1 Answer 1

2

There is an idea for this. But it was submitted more than 10 years ago and Salesforce has not even posted a reaction to it (despite more than 1,000 votes).

So, no help coming from that direction. But, as happens occasionally, it pays to scroll down the list of comments: more than once, a work-around is posted. In this case as well, the work-around is from Nick Saiben. I am posting it here, as looking it up in the idea takes a lot of scrolling and clicking.

As dashboard filters seem to prefer date fields for filtering, the idea (no pun intended) is to convert the field that you want to filter on to a date.

In Nick’s case, he needed a filter on a division, so he created a custom formula field with these contents:

CASE( Division__c,
"North", DATE(2018,1,1),
"South", DATE(2018,2,2),
"East", DATE(2018,3,3),
"West", DATE(2018,4,4),
null
)

Create such a field for all the objects that you want to see in the dashboard, add it to the reports that are the components of the dashboard, and you will see that it is offered as an option for a filter field. You may need to select it as the filter field for each report in the dashboard.

Because Salesforce allows us to use labels for filter options, we can hide the date construction from the users. They only see North, South, etc.

Only when they open a report from the dashboard, they will see some strange date field, but in my opinion, that is a minor price to pay for this gained functionality.

Many thanks to Nick for this great work-around!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .