2

I tried adding user provisioning to mcdev but currently I am running into a road-block when it comes to adding the default "Marketing Cloud ..." roles (e.g. "Marketing Cloud Administrator") to users. Adding any other role works just fine. Removing any role as well, including these default "Marketing Cloud ..." roles. The API-return looks perfectly good as well. But when I then check the GUI or try to retrieve that particular user via API, all added roles show up correctly, EXCEPT for the default "Marketing Cloud ..." roles.

sample request body:

<Envelope xmlns="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Body>
        <UpdateRequest xmlns="http://exacttarget.com/wsdl/partnerAPI">
            <Objects xsi:type="AccountUser">
                <CustomerKey>testNew_user3</CustomerKey>
                <UserID>[email protected]</UserID>
                <Name>new user</Name>
                <Email>[email protected]</Email>
                <MustChangePassword>false</MustChangePassword>
                <ActiveFlag>false</ActiveFlag>
                <IsAPIUser>false</IsAPIUser>
                <NotificationEmailAddress>[email protected]</NotificationEmailAddress>
                <IsLocked>false</IsLocked>
                <DefaultBusinessUnit>518001150</DefaultBusinessUnit>
                <AssociatedBusinessUnits__c>518001150</AssociatedBusinessUnits__c>
                <Client>
                    <ID>1111111</ID>
                </Client>
                <Roles>
                    <Role>
                        <ObjectID>f1cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                        <Name>Administrator</Name>
                    </Role>
                    <Role>
                        <ObjectID>fdcfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                        <Name>Distributed Sending User</Name>
                    </Role>
                    <Role>
                        <ObjectID>f6cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                        <Name>Data Manager</Name>
                    </Role>
                    <Role>
                        <ObjectID>f4cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                        <Name>Content Creator</Name>
                        <AssignmentConfigurations>
                            <AssignmentConfiguration>
                                <AccountUserId>717510285</AccountUserId>
                                <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                <IsDelete>false</IsDelete>
                            </AssignmentConfiguration>
                        </AssignmentConfigurations>
                    </Role>
                    <Role>
                        <ObjectID>63a50610-315c-e111-beee-8e001800001f</ObjectID>
                        <Name>Marketing Cloud Administrator</Name>
                        <AssignmentConfigurations>
                            <AssignmentConfiguration>
                                <AccountUserId>717510285</AccountUserId>
                                <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                <IsDelete>false</IsDelete>
                            </AssignmentConfiguration>
                        </AssignmentConfigurations>
                    </Role>
                </Roles>
                <AccountUserID>717510285</AccountUserID>
            </Objects>
        </UpdateRequest>
    </Body>
    <Header>
        <fueloauth xmlns="http://exacttarget.com">...removed...</fueloauth>
    </Header>
</Envelope>

Note how I AssignmentConfigurations for roles that I want to add and not for those that already existed. This is NOT a requirement - you can add all other roles without that section but it also didn't hurt - unless you are creating a user because it requires the AccountUserId property which you wouldn't have during creation.

The Content Creator role was actually added after this call while the Marketing Cloud Administrator role was not. I also tried adding them without that section, and without providing the Name property. No luck so far.

Meanwhile, the response body states that everything is OK in all those cases.

matching response body:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"
    xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"
    xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <soap:Header>
        <wsa:Action>UpdateResponse</wsa:Action>
        <wsa:MessageID>urn:uuid:fcd51ccf-6127-4f95-81db-494780bdf60e</wsa:MessageID>
        <wsa:RelatesTo>urn:uuid:75f520b2-54ac-4fd8-ae1f-1c5f6f5e46f6</wsa:RelatesTo>
        <wsa:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To>
        <wsse:Security>
            <wsu:Timestamp wsu:Id="Timestamp-72aa12b6-b1b0-4664-bebf-c6121e32fb3c">
                <wsu:Created>2023-03-13T14:04:07Z</wsu:Created>
                <wsu:Expires>2023-03-13T14:09:07Z</wsu:Expires>
            </wsu:Timestamp>
        </wsse:Security>
    </soap:Header>
    <soap:Body>
        <UpdateResponse xmlns="http://exacttarget.com/wsdl/partnerAPI">
            <Results>
                <StatusCode>OK</StatusCode>
                <StatusMessage>Account User Updated / Created</StatusMessage>
                <OrdinalID>0</OrdinalID>
                <Object xsi:type="AccountUser">
                    <Client>
                        <ID>1111111</ID>
                    </Client>
                    <PartnerKey xsi:nil="true" />
                    <ID>717510285</ID>
                    <ObjectID xsi:nil="true" />
                    <CustomerKey>testNew_user3</CustomerKey>
                    <AccountUserID>717510285</AccountUserID>
                    <UserID>[email protected]</UserID>
                    <Password />
                    <Name>new user</Name>
                    <Email>[email protected]</Email>
                    <MustChangePassword>false</MustChangePassword>
                    <ActiveFlag>false</ActiveFlag>
                    <Delete>0</Delete>
                    <IsAPIUser>false</IsAPIUser>
                    <NotificationEmailAddress>[email protected]</NotificationEmailAddress>
                    <IsLocked>false</IsLocked>
                    <DefaultBusinessUnit>518001150</DefaultBusinessUnit>
                    <Roles>
                        <Role>
                            <Client>
                                <ID>1111111</ID>
                                <EnterpriseID>1111111</EnterpriseID>
                            </Client>
                            <PartnerKey xsi:nil="true" />
                            <ObjectID>f1cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                            <Name>Administrator</Name>
                            <AssignmentConfigurations>
                                <AssignmentConfiguration>
                                    <AccountUserId>717510285</AccountUserId>
                                    <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                </AssignmentConfiguration>
                            </AssignmentConfigurations>
                        </Role>
                        <Role>
                            <Client>
                                <ID>1111111</ID>
                                <EnterpriseID>1111111</EnterpriseID>
                            </Client>
                            <PartnerKey xsi:nil="true" />
                            <ObjectID>fdcfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                            <Name>Distributed Sending User</Name>
                            <AssignmentConfigurations>
                                <AssignmentConfiguration>
                                    <AccountUserId>717510285</AccountUserId>
                                    <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                </AssignmentConfiguration>
                            </AssignmentConfigurations>
                        </Role>
                        <Role>
                            <Client>
                                <ID>1111111</ID>
                                <EnterpriseID>1111111</EnterpriseID>
                            </Client>
                            <PartnerKey xsi:nil="true" />
                            <ObjectID>f6cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                            <Name>Data Manager</Name>
                            <AssignmentConfigurations>
                                <AssignmentConfiguration>
                                    <AccountUserId>717510285</AccountUserId>
                                    <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                </AssignmentConfiguration>
                            </AssignmentConfigurations>
                        </Role>
                        <Role>
                            <Client>
                                <ID>1111111</ID>
                                <EnterpriseID>1111111</EnterpriseID>
                            </Client>
                            <PartnerKey xsi:nil="true" />
                            <ObjectID>f4cfb80f-3550-e611-96fe-38eaa7142c61</ObjectID>
                            <Name>Content Creator</Name>
                            <AssignmentConfigurations>
                                <AssignmentConfiguration>
                                    <AccountUserId>717510285</AccountUserId>
                                    <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                    <IsDelete>false</IsDelete>
                                </AssignmentConfiguration>
                            </AssignmentConfigurations>
                        </Role>
                        <Role>
                            <Client>
                                <ID>1111111</ID>
                                <EnterpriseID>1111111</EnterpriseID>
                            </Client>
                            <PartnerKey xsi:nil="true" />
                            <ObjectID>63a50610-315c-e111-beee-8e001800001f</ObjectID>
                            <Name>Marketing Cloud Administrator</Name>
                            <AssignmentConfigurations>
                                <AssignmentConfiguration>
                                    <AccountUserId>717510285</AccountUserId>
                                    <AssignmentConfigureType>RoleUser</AssignmentConfigureType>
                                    <IsDelete>false</IsDelete>
                                </AssignmentConfiguration>
                            </AssignmentConfigurations>
                        </Role>
                    </Roles>
                </Object>
            </Results>
            <RequestID>f4b0d243-e7de-4b4f-aeb2-8165f412eca8</RequestID>
            <OverallStatus>OK</OverallStatus>
        </UpdateResponse>
    </soap:Body>
</soap:Envelope>

I should mention that I am getting the correct Object IDs for those roles via REST API: /platform/v1/setup/quickflow/data:

{
    "languages": [
        ...
    ],
    "roles": [
        {
            "roleID": "f1cfb80f-3550-e611-96fe-38eaa7142c61",
            "roleName": "Administrator",
            "description": "Administrator"
        },
        ...
        {
            "roleID": "63a50610-315c-e111-beee-8e001800001f",
            "roleName": "Marketing Cloud Administrator",
            "description": "Assign Marketing Cloud roles to users and manage Mobile, Social and Sites Channels, Marketing Cloud Apps and Tools."
        },
        {
            "roleID": "66a50610-315c-e111-beee-8e001800001f",
            "roleName": "Marketing Cloud Channel Manager",
            "description": "Create and execute cross-channel interactive marketing campaigns and administer Social and Mobile Channels"
        },
        {
            "roleID": "64a50610-315c-e111-beee-8e001800001f",
            "roleName": "Marketing Cloud Content Editor/Publisher",
            "description": "Create and deliver messages through Mobile and Sites Channel Apps"
        },
        {
            "roleID": "67a50610-315c-e111-beee-8e001800001f",
            "roleName": "Marketing Cloud Security Administrator",
            "description": "Maintain Watchdog security settings and manage user activity and alerts"
        },
        {
            "roleID": "65a50610-315c-e111-beee-8e001800001f",
            "roleName": "Marketing Cloud Viewer",
            "description": "View cross-channel marketing activity and results within the Marketing Cloud"
        }
    ],
    "timeZones": [
        ...
    ],
    "defaultUserData": {
        "defaultTimeZone": "5",
        "defaultLanguage": "en-GB"
    }
}

1 Answer 1

1

You are doing the correct call and I have also tried it on my end and with Add&Update Data Action. Moreover, tried to retrieve and then assign to a user with WSProxy and still got no luck. It seems that those "Marketing Cloud..." roles are not retrievable as well as not assignable.

There has been a similar discussion on AccountUser object retrieval here, which only shows that there is indeed something not working. Unfortunately, I have not found any opened Known Issues on that topic.

Try opening a SF Support Case explaining all of that and asking for the explanation and opening a Known Issue.

2
  • I should mention that I am getting the correct Object IDs for those roles via REST API as mentioned in the post you reference: /platform/v1/setup/quickflow/data Mar 14, 2023 at 8:10
  • Even though you got the correct ObjectID, it is not possible to create the user with this role, Issue is those roles can not be found in Role OBJECT while doing the Retrieve, I don't know why, but this is something that has to be fixed. All Marketing Cloud XX roles can't be created except for Marketing Cloud Campaign Creator, the others are not assignable sadly.
    – TaouBen
    Mar 16, 2023 at 5:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .