I'm trying to figure out what's wrong with my search panel in VSCode when searching in a branch from BitBucket. When I try to look for a specific search term, it doesn't find ALL instances of that term (I know for sure it's missing). For example, when I search for Send_to_a_delivery_company__c, it finds me all profiles using it, and all open editors that have that instance

search results no open editor

When I open some file that has this instance, it´s being added to the list editor with opened class

I tried using all kinds of glob includes, and it actually finds all the results when I try *.cls search results with *.cls

But when I try the directory, for example, it doesn't find any results...

search results - nothing found with directory glob include

I watched this amazing video to see what can be done, and I tried the following:

  1. Using glob include - as described above, only *.cls worked.
  2. disabled use exclude settings and ignore files - The results remained the same.
  3. Settings > Search Ignore - disabled. Remained the same.
  4. Settings > Search Exclude - removed the default settings. Remained the same... I reset the setting to the default after that.

I will mention that this problem is ONLY for Bitbucket branches (all of them - master or new branches). I have colleagues who are using the same bitbucket workspace and it's working fine for them.

2 Answers 2


Your directory search is currently ./classes, which is terminal. It would only ever find that folder itself, not any files inside it. You want instead */classes/*, which does not require the directory to be the terminus.

  • ./classes/* doesn't match force-app/main/default/classes. . always refers to the root folder.
    – sfdcfox
    Commented Mar 13, 2023 at 13:46
  • I was assuming he had verified that part of it, my mistake.
    – Adrian Larson
    Commented Mar 13, 2023 at 14:33
  • This was just an example of how I tried to narrow the search to "force" it to find the right instances, but it didn't. My end goal is to have all search results show up on the most basic search option, not to have to include directory or file type every time I search. Commented Mar 13, 2023 at 17:53

I managed to solve the issue at last... Apparently, I cloned the project in the wrong way... Instead of using the "Clone" button (and copying the repository with the .git suffix), I copied the URL from the repository which did actually clone but the structure was somehow corrupted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .