0

I'm trying to run the SalesForce Code Analyzer on the new version 3 to a unique method called deleteQuery and the deleteQuery has a parameter Id here what I'm using: "sfdx scanner:run:dfa --target./force-app/main/default/classes/accountController.cls#deleteQuery --projectdir ./force-app/main/default --outfile ./reports/thirdRun.csv --format=csv"

@RemoteAction
    public static List<String> deleteQuery(String qId) {

        Schema.DescribeSObjectResult dsrListQuery = account.sObjectType.getDescribe();
        if (Schema.SObjectType.account.isDeletable() && Schema.SObjectType.account.isQueryable()) {
            account deletequery = new account(Id = qId);
            delete deletequery ;
            return new List<String>;
        }
        return null;
    }

but I'm receiving this message: "zsh: no matches found: ./force-app/main/default/classes/accountController.cls#deleteQuery", but the method exists.

Is it because the method has a parameter?

3
  • Have you tried to add simple quotes on the target path? Commented Mar 2, 2023 at 22:48
  • Yes, but when I tried to add simple quotes I got this message: 'zsh: no matches found: ‘./force-app/main/default/classes/accountController.cls#deleteQuery’' Commented Mar 3, 2023 at 15:54
  • hmm, have you tried to update the sfdx-cli? Commented May 12, 2023 at 12:51

0

You must log in to answer this question.