2


I'm working on a form that is going on a digital experiences website. I've made the form using Flow, and I have one screen that contains a LWC. The LWC and flow has no errors in Preview and Debug mode in the Flow editor. But when I access the flow on the website I get the following error when I get to my LWC component: Something went wrong with the "Location" screen component on the "Sign Up" flow. Contact your Salesforce admin about this error. LWR3008: Error loading https://redacted.develop.my.site.com/webruntime/component/latest/prod/en-US/c%2Flocation_Picker

The follow errors show up in my console when the flow screen loads.

GET https://redacted4-dev-ed.develop.my.site.com/webruntime/component/latest/prod/en-US/c%2Flocation_Picker net::ERR_ABORTED 404 (Not Found)


Refused to execute script from 'https://redacted4-dev-ed.develop.my.site.com/webruntime/component/latest/prod/en-US/c%2Flocation_Picker' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

My only guess so far as to what is causing this is my LWC xml file not having the required target for a digital experiences website. (XML Below) But I do not know what the target would be.

<?xml version="1.0" encoding="UTF-8"?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata">
    <apiVersion>56.0</apiVersion>
    <isExposed>true</isExposed>
    <targets>
      <target>lightning__FlowScreen</target>
    </targets>
    <targetConfigs>
        <targetConfig targets="lightning__FlowScreen">
            <property name="selectionMode" type="String" label="Selection Mode" role="outputOnly"></property>
            <property name="selectedRegions" type="String[]" label="Selected Regions" role="outputOnly"></property>
            <property name="selectedRegionsString" type="String" label="Selected Regions String" role="outputOnly"></property>
            <property name="getMarkerLat" type="Integer" label="Marker Latitude" role="outputOnly"></property>
            <property name="getMarkerLong" type="Integer" label="Marker Longitude" role="outputOnly"></property>
            <property name="getRadius" type="Integer" label="Marker Radius" role="outputOnly"></property>
        </targetConfig>
    </targetConfigs>
</LightningComponentBundle>
8
  • 1
    What is the template of the digital experience site? Also, do you see any error in the browser console? Feb 23, 2023 at 9:23
  • 1
    Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Feb 23, 2023 at 15:23
  • @Swetha I am using the Build Your Own (LWR) Template Feb 23, 2023 at 22:41
  • @Community My issue is that when I access my flow on my digital experiences website, I get the error above when I click to the flow screen containing my LWC. In flow preview and debug this error doesn't show and the LWC works as intended Feb 23, 2023 at 22:43
  • @Swetha I have edited my question with browser console errors Feb 23, 2023 at 22:49

1 Answer 1

0

This happens with LWR Experience Sites, updating the LWC is not properly reflected in the site. To fix this you need to publish the LWR site each time you updated your LWC embedded in flow.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .