We have 2 branches, 1 Canadian and 1 American. We assign a branch to each user on their profiles as well as assign a branch to the object.

I want to be able to restrict a Canadian user from seeing an object with an American branch or vice versa.I am trying to acheive this via restriction rules but it is not working. Is there a better way?


1 Answer 1


So, first thing that comes to mind here is Sharing Settings; to get those to work, though, you're also going to need to get rid of "view all" permissions for your users on the corresponding objects (this is located in the "object settings" section of their profiles). You may also need to check the organization-wide defaults (also in "Sharing Settings") and make sure default access for the objects in question is "Private".

Removing view-all permissions will mean your users can only see the records they "own"; after that, you can add in your sharing rules, which mostly work how you'd expect. They're somewhat limited in who they let you share with, though: Public Groups are pretty much your only out-of-the-box choice if you want your audiences to overlap without being complete subsets.

(Which might not be relevant for you; "Canadian user" and "American user" rolling up to "North American Manager" works perfectly fine using Roles, provided you use multiple sharing rules)

  • I've just set the org-wide defaults to that object to private. Where exactly are the view all permissions on the object? I can find them in profiles but not on the object itself.
    – Morgado.b
    Feb 20 at 17:00
  • Sorry, that was probably ambiguous wording on my part. You're correct, they're in the Profiles section, not the Object Manager section. Odds are most profiles already have that disabled. Feb 21 at 14:05
  • Hey thanks this did end up working!
    – Morgado.b
    Feb 27 at 20:48
  • You're welcome. Mark it as an answer, then? Feb 27 at 20:57

Not the answer you're looking for? Browse other questions tagged .