I keep getting errors while installing the Local Development Server. I referred to many possible solutions online. I have the following things installed already. Visual Studio Code, Salesforce CLI, Python, Node.js.

All have been installed in the last few days.

Gave the following command several times from the command prompt: sfdx plugins:install @Salesforce/lwc-dev-server

Latest error received :

ShellExecError: npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.npmjs.org/@Salesforce%2flwc-dev-server - Not found
npm ERR! 404
npm ERR! 404  '@Salesforce/lwc-dev-server@latest' is not in this registry.
npm ERR! 404 This package name is not valid, because
npm ERR! 404  1. name can no longer contain capital letters
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.
  "error": {
    "code": "E404",
    "summary": "Not Found - GET https://registry.npmjs.org/@Salesforce%2flwc-dev-server - Not found",
    "detail": "\n '@Salesforce/lwc-dev-server@latest' is not in this registry.\nThis package name is not valid,
because \n 1. name can no longer contain capital letters\n\nNote that you can also install from a\ntarball,
folder, http url, or git url."

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Iblox\AppData\Local\npm-cache\_logs\2023-02-09T06_19_28_628Z-debug-0.log

Code: ShellExecError
  • I need to update. Something magical happened. The Local Development Server got installed. A couple of hours ago I had ran the command 'npm install --global --production windows-build-tools' and immediately after that I ran 'sfdx plugins:install @salesforce/lwc-dev-server' again. Then I just now looked at the command line properly and this is what I saw. 'Installing plugin @salesforce/lwc-dev-server... installed v2.11.0'. Then I started it and it and it worked. Finally. What a relief.
    – AB L
    Commented Feb 9, 2023 at 12:14

2 Answers 2


It seems the issue is with your command. In @salesforce the letter 's' should be small, in your command it is capital.

sfdx plugins:install @salesforce/lwc-dev-server
  • Hi Saroj, Thanks for the response. I just checked on the command prompt. The S is in small case. While posting here I accidentally typed the S in upper case.
    – AB L
    Commented Feb 9, 2023 at 12:04
  • But In your error text, it is clearly visible that the letter S is in capital. Even the error message says so 1. name can no longer contain capital letters
    – Saroj Bera
    Commented Feb 9, 2023 at 13:02
  • Oh yes. You are right. One one of the occasions, I must have run it with a capital S. Thanks for pointing that out. Appreciate your help.
    – AB L
    Commented Feb 10, 2023 at 13:37
  • Hi Saroj, Though I had already taken corrective action. What you posted was very correct. Accepting you answer as the solution. Thanks again
    – AB L
    Commented Feb 12, 2023 at 11:22

The issue that was occurring. It because some "C++ Build Tools" were missing in VS Code or the system.

To resolve the issue, download "Visual Studio Build Tools" from: https://visualstudio.microsoft.com/downloads/

Then, install "C++ Build Tools" from that source. The issue is now resolved, and the server is running smoothly.

Note: Select all "C++ Build tools" while Installing C++ build tools. enter image description here enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .