1

I have a custom picklist that in an LWC datatable. I would like to eliminate the space above the picklist.

Aligning the picklist field has been challenging: enter image description here

custom picklist:

<div class="slds-m-right_none slds-m-top_none slds-align_absolute-center" style="overflow: visible;">
    <lightning-combobox
        name="picklist"
        label={typeAttributes.label}
        value={typeAttributes.value}
        placeholder={typeAttributes.placeholder}
        options={typeAttributes.options} >
    </lightning-combobox>
</div>

custom datatable:

<div class="slds-m-right_none slds-m-top_none slds-align_absolute-center" style="overflow: visible;">
    <c-custom-types-global
            key-field="Id"
            data={taskResourceList}
            columns={columns}
            hide-checkbox-column
            onsave={handleSave}
            draft-values={draftValues}>
    </c-custom-types-global>
</div>

1 Answer 1

3

That blank space is supposed to be the label of the input field. For some reason, your attribute label={typeAttributes.label} doesn't have a value. I assume if you add an attribute variant="label-hidden" it will fix your issue.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .