I retrieved a translation metadata via the Metadata API with the following package.xml:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">

What I got was the following da.translation file:

<?xml version="1.0" encoding="UTF-8"?>
<Translations xmlns="http://soap.sforce.com/2006/04/metadata">
        <label><!-- Accounting --></label>

    <!-- some more lines of XML here -->

        <label><!-- New Case --></label>

    <!-- some more lines of XML here -->


What I did next was setting up the label for the New_Case_Quick_Action Quick Action and then deploying it back to the same Environment. Couldn't do so, though, as I received an error:

In field: name - no QuickAction named New_Case_Quick_Action found

After an investigation, it turned out that it is a managed package-owned Action on the Account object. It creates a new Case. I can translate it in the Translation Workbench at the "Override" section.

I don't mind translating some components manually, but does anybody know why were they retrieved to the da.translation file in the first place if they are impossible to deploy? Is there any workaround to this problem?

Possible hint (?): It's a Sandbox created out of the already functioning Production environment with a couple of packages installed. Maybe I should reinstall some?

  • Have you tried changing the name in the file to namespace__New_Case_Quick_Action, where you substitute the package's namespace in place of namespace?
    – Phil W
    Jan 26 at 7:23
  • @PhilW wow, it worked, thanks for that. But here comes the hard part - I have 30k-lines XML in front of me and it looks like I would need to update a pretty big chunk of code. Isn't there really any other way to handle these translations? Jan 26 at 10:29
  • Exactly how did you get the XML exported in the first place? It should include the namespace automagically... it rather seems like a bug in the API...
    – Phil W
    Jan 26 at 10:34
  • @PhilW In a couple of ways: 1. In VSC - right click on the package.xml that I provided in the question -> SFDX: Retrieve Source in Manifest from Org || 2. A direct command in PowerShell sfdx force:mdapi:retrieve -r .\manifest -k .\manifest\translations.xml --unzip, where translations.xml is the same as mentioned before. || 3. A direct command in PowerShell sfdx force:source:retrieve -m Translations:da || Always the same result, a 30k-liner with content without specified namespaces. Jan 26 at 11:40
  • 1
    I suggest you raise a support case. This sounds like a bug.
    – Phil W
    Jan 26 at 11:44


You must log in to answer this question.

Browse other questions tagged .