Case Feed Object's field 'Body' is not showing up on filter - Reports..But I am able to add the field 'Body' as column on reports enter image description here

  • What is the report type used here, Can you include report type screenshot as well ?
    – Vinay
    Jan 20 at 16:03

2 Answers 2


In general, you can't filter on long text area fields. That's just a limitation of how reports/SOQL works. You can verify if a field is filterable using an Execute Anonymous script:

// Assertion fails, because Body is not filterable.

Verify if 'Encrypt chatter' is enabled in your org under Setup -> encryption policy. If so, casefeed.body field will be visible in report but not be filterable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .