0

I created a Screen flow to capture basic lead information (first name, last name, email).

When I run the Debug, I get this error:

Error Occurred: This error occurred when the flow tried to create records: REQUIRED_FIELD_MISSING: Required fields are missing: [Company].

When I edit 'Create Records', what should I match the Company field as this field doesn't exist on my flow? Is there a way to display 'Not provided' on the Lead's Company field in Salesforce once the user submits the flow?

Thank you.

[Edit]

enter image description here

7
  • Do you want company name to be Not Provided when lead is created from screenflow? Dec 7, 2022 at 12:42
  • @SaiPraveenKakkirala Yes ideally - I need the Company field to be filled in somehow but I don't know how to set it up in the 'Create Reports' under Set Field Values for the Lead.
    – Maria C.
    Dec 7, 2022 at 13:59
  • Can you share the create records component screenshot so can share the process for it Dec 7, 2022 at 14:00
  • 1
    In the same way how you defined Leadsource and status . In similar way define Company field with Value as 'Not Provided' Dec 7, 2022 at 14:08
  • 1
    Lead.Company is a required field per the schema - it just needs to be non-null when the record is saved (though check to make sure your Duplicate Rules can accommodate a constant value here)
    – cropredy
    Dec 7, 2022 at 17:06

1 Answer 1

0

As confirmed in the above comments you can default the lead company field to "No Information" like you did it for Status and LeadSource fields in Screen.

As highlighted by @cropredy check to make sure your Duplicate Rules can accommodate a constant value here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .