0

We are seeing an error message for one specific user in Workbench when attempting to query the Task Object. This user has access to Task records in Salesforce, but for some reason sees this error in Workbench: "Unknown error: Object of class __PHP_Incomplete_Class could not be converted to string"

We have tried adjusting the query to reduce or specify the results, but we still see this error. Does anyone know what is causing this?

enter image description here

1
  • 1
    try running workbench at v54.0
    – cropredy
    Dec 1, 2022 at 21:04

1 Answer 1

0

Workbench is not officially supported by salesforce, However you can try below check points which might resolve issue.

We have seen this issue occur due to high number of records where indexing resolved the issue, try to index any fields in the where clause to see if that improves query performance.

Try to optimize or put more filters in the where clause to narrow down the results. See documentation to make a query selective.

Also check similar details and take a look at clearing cache as mentioned here.

2
  • Thank you! We've narrowed the query to <100 records, so I don't think we are hitting that many records. We've attempted browser cache clearing, but haven't tried anything server-side. Is this something we can access directly in Workbench?
    – Chad
    Dec 5, 2022 at 19:47
  • No, I don't think you will be able to do anything on server-side as we only have limited access.
    – Vinay
    Dec 6, 2022 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .