We have an experience site set up. It's all protected and published on a custom domain url. Whenever the user enters the url to the browser (e.g. https://www.example.com ) she'll be taken to the login page, however there is already a red error message "To access this page you have to log in to Example Portal.".

This is because salesforce redirects https://www.example.com to https://www.example.com/s which is redirected to https://www.example.com/login?ec=302&startURL=%2Fs%2F.

This is pretty annoying. Is there a way around this?

The expected behavior would be a simple https://www.example.com -> https://www.example.com/login without any message.

The site works otherwise without issues, this is just a small annoyance.

1 Answer 1


Check to make sure your Experience Cloud site is both active in the Administration settings of the Site but also Published from within the Experience Builder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .