1

I am trying to perform Resource Owner Authentication on Salesforce production org using Postman.

I am sending the following details for authentication from Salesforce

For POST Method I am using the following URL - https://login.salesforce.com/services/oauth2/token

I am sending the following body for the request

Please note I have replaced the text with - and *

 grant_type=password&username=madhurima@------------.com&password=********&client_id=3MVG9YDQS5WtC11rvyk58hBNQQsaPVyf25lCfEOK6NrcCpzL*****************.*****&client_secret=7EEF965373CDA66B94DF185C341***********************************

My problem here is that I am getting the access token correctly when I call my developer org, but if I try to send the same request (changing the Id, Password, ClientId and Client Secret) to my production org, I am getting the following error

 {
"error": "invalid_grant",
"error_description": "authentication failure"

}

I am not sure what is wrong in here. I created connected apps in both the orgs with similar authorizations. I also tried adding my security token with my password, but it didn't work

1 Answer 1

1
  1. Please Go to Manage App
  2. Click on the Connected App you created.
  3. On click, you have to change "IP Relaxation" setting to "Relax IP Restrictions". With this setting you can resolve such issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.