0

I created a Messaging User record linked to an active SMS channel and added the 'Start Conversation' button to the layout, yet I don't see it on the page.

According to this article, I should be able to see the button https://help.salesforce.com/s/articleView?id=sf.messaging_agent_initiated_outbound.htm&type=5

Consent status is set to implicitly opt-in and I am a member of the queue associated with the SMS channel, I also have the messaging license assigned to my user. Is there anything else I'm missing?

Thanks

1 Answer 1

0

I see you have also logged a Salesforce support case for this issue. Copying the resolution provided so it might help others in future

To access the start conversation we need to have the below permissions on the user record.

  • Agent Initiated Outbound Messaging AND Messaging Agent
  • End Messaging Session

Upon checking the below permission sets in your org related to messaging the above permissions weren't enabled under app permissions for these permission sets.

  • Messaging License Perm Set
  • Messaging Permissions
  • Messaging Permissions Admin

Clickpath: Setup>permissions sets>Messaging Permissions>App permissions>enable the "Agent Initiated Outbound Messaging AND Messaging Agent" and "End Messaging Session"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .