I'm just getting started with developing in VS Code and have been following the steps here.

I was able to authorise my org with the default alias according to the steps here:

enter image description here

The authorised org also shows up in my auth:list:

enter image description here

And running sfdx force:org:display --targetusername vscodeOrg, confirms the org's Connected Status: Connected.

But when I try to deploy the component as per step 2 here with SFDX: Deploy Source to Org, I get the error message No authorization information found for vscodeOrg:

enter image description here

Would anyone know what's going on here? I can't find much information about this error and I'm worried I've broken something, so any help would be much appreciated.

EDIT: Updating the CLI with sfdx update seemed to resolve the issue for me.

  • As an aside, if you are just starting out with VSCode and sfdx, consider using scratch orgs and git for your development and version control.
    – Phil W
    Commented Oct 30, 2022 at 7:14
  • 3
    I also faced the same issue. Restarting the VS Code worked for me.
    – Tushant
    Commented Oct 31, 2022 at 16:43

7 Answers 7


I had the same issue. I restarted Vscode and after that it worked.


I am facing this kind of error a lot recently.
For me none of these update sfdx or restarting VScode works.
In my case, when I execute SFDX: Authorize an Org and then execute sfdx force:org:list, there is connected org but no default org.

if you are facing same problem, execute sfdx force:config:set [email protected], which works for me.


sfdx update took care of this issue for me.


In my situation, authorizing the org once again or switching the default org to a different one and switching back and then deploying the component worked

  1. If there is an update in sfdx kindly update it to the latest version
  2. Restart your VS Code
  3. Then type in force:org:display -a which would display the org details such as the connection status
  4. If disconnected then reconnect it again by using SFDX:Authorize and Org

In my case what helped was to run the following command from the VScode's terminal:

sfdx force:org:list --all

I ran into the same issue. What helped for me was configuring the path to JAVA in VSCode. https://developer.salesforce.com/tools/vscode/en/vscode-desktop/java-setup

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .