Summary: My POST operation fails, but my GET operation works.

Details: I have successfully created an External service, using an OpenAPI API Spec with 3 endpoints. No auth is required. 3 endpoints have been exposed as Flow Actions.

  1. /ping - GET
  2. /issue - POST
  3. /issue/{issueId} - POST

In the flow, the action associated with the first and 3rd endpoints works fine. However, the 2nd endpoint fails with a "The URI is invalid" error

Looking at the debug logs, I see the following, which clearly shows the correct endpoint for the first operation, on the NAMED CREDENTIAL REQUEST line, but a lack of a matching NAMED_CREDENTIAL_REQUEST line on the second callout operation.

So I can't actually inspect the Endpoint for the second operation.

See screenshot for log line detail.

screenshot of flow log lines

The actual line with the endpoint data for the first call is this:

15:40:03.549 (549227042)|NAMED_CREDENTIAL_REQUEST|NamedCallout[Named Credential Id=0XA3t000000kDV9, Named Credential Name=DemoDataCalloutq, Endpoint=https://anypoint.mulesoft.com/mocking/api/v1/sources/exchange/assets/372178e4-0d6f-xxxx-8c1f-ae1556e32e0c/employee-experience-api-oas/1.0.0/m/ping?checkDependencies=true, Method=GET, External Credential Type=EXTERNAL, HTTP Header Authorization=Not Set, Content-Type=application/json; charset=UTF-8, Request Size bytes=-1, Retry on 401=True]

I have tried moving the errant endpoint callout to be the first action that the flow fires. Again, there is no NAMED_CREDENTIAL_REQUEST.

I have tried to catch the fault in the flow for more detail. no luck there either. the fault gives me a gnarly red error message in the flow UI.

Any ideas on how to better troubleshoot this callout?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy