0

For a flow on the Contact object, I can select the HasOptedOutOFEmail field in decision nodes (so for reading its value), but I cannot select it in an update-record node.

I have checked the Field Level Security of the field several times and all profiles can see it and all profiles are allowed to change it.

What am I missing?

5
  • What do you mean it can't be updated by a flow? Have you tried setting its value in a variable and then trying to use the "update record" node to update the variable? Sep 26, 2022 at 13:12
  • HasOptedOutOFEmail is simply not available as a field to be updated. Sep 26, 2022 at 14:02
  • That is really weird. I tested in a production org and this is available in the flow. I am able to select the field in both assignment and update record elements. Sep 26, 2022 at 16:48
  • @SanderdeJong maybe the field label is translated to some other text which could be possible reason why cannot be found with the std name. Cross check under settings, rename tabs and labels
    – Shamina
    Sep 26, 2022 at 19:31
  • No, that's not it either. Flow is quite flexible in this: you can search by label or by API name. Anyway, I have scanned the list of all fields already several times and it's just not there. I was wondering if other people can see it in their list of updatable Contact fields, or if it is something specific for my org. Sep 27, 2022 at 6:19

1 Answer 1

0

I have no idea what has happened, but I reopened my flow, simply tried it again, and now I was able to select the HasOptedOutOFEmail field in an update-record node.

I am the only person active on this sandbox, it's not as if another admin might have changed permissions.

Apologies to those who spent time looking at this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .