2

To set up SFDX , first I did install CLI and when I tried updating the same, I'm facing this issue. Can anyone please help me out.

1

3 Answers 3

0

Likely you have a proxy or something (like zscaler) in the way of the TLS connection. Either work out the nodej SSL config or simply bypass by running: set NODE_TLS_REJECT_UNAUTHORIZED=0

0

It is likely because you are using a VPN.

So temporarily disable your VPN/firewall then do the sf update command.

0

After my company started using ZScaler, I was also unable to retrieve and deploy code. The command about did not work for me. I needed to get with my IT department and have them add the following URL's to the ZScaler allow list:

https://developer.salesforce.com/media/salesforce-cli https://registry.npmjs.org

Reference: https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli_firewall.htm?_ga=2.35608489.947861749.1720464910-2081861193.1720448679

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .