0

I am trying to Retrieve Source from Org and I get this error:

UNSUPPORTED_API_VERSION: Invalid Api version specified on URL

In package.xml, it shows me:

<version>54.0</version>

With this command sfdx version

it shows me

sfdx-cli/7.165.0 win32-x64 node-v16.17.0

With this command sfdx force

WARNING: apiVersion configuration overridden at "54.0"

and with this sfdx plugins ,it show me

>> salesforcedx 51.16.0
salesforcedx 52.0.0
├─ salesforce-alm 52.0.0
├─ data 0.4.11
├─ apex 0.2.2
├─ custom-metadata 1.0.12
├─ org 1.6.6
├─ schema 1.0.7
├─ limits 1.2.1
├─ templates 51.5.0
├─ user 1.3.0
└─ @salesforce/sfdx-plugin-lwc-test 0.1.7

what can I do to fix it?

1 Answer 1

0

This may help: How do I reset the SFDX CLI Runtime Global Configuration Values?

Also check the API version specified in your sfdx-project.json file

4
  • Welcome to Salesforce SE! While this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – identigral
    Commented Aug 31, 2022 at 23:40
  • 1
    Thanks @identigral, I'll update the answer when I'm back at office. Cheers for the tip!
    – BenBates
    Commented Sep 1, 2022 at 0:01
  • Hi! the version of the sfdx-project.json is 54.0 Commented Sep 1, 2022 at 14:59
  • What I did was delete: Visual Studio Code, Salesforce CLI, .vscode folder, .sf folder, .sdfx folder and reinstall everything. Commented Sep 1, 2022 at 17:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .