0

I have built a flow which is triggered from the process builder and on the flow I have put a pause element before updating a record, we added the pause element to avoid the SOQL 101 error as pause element will continue the process in a new transaction with new limits. however when I am testing the functionality the pause element is not resuming after 30 seconds. What could be the issue.

Attached are the screenshots.enter image description hereenter image description hereenter image description here

enter image description here

Quick update: The pause element is resuming but I see that it takes 15 minutes to update the record when I kept the resume time for 30 seconds only, is it due to the resources not available to it until 15 minutes?

1 Answer 1

3

The server checks for pending automations every 15 minutes, starting from the time the server is brought up. That means it will take up to 15 minutes to resume. This is true for Time-Based Workflows, Process Builder, Escalation Rules, and so on.

4
  • Is it true for platform event based pause too?
    – vishesh
    Jun 19, 2023 at 4:17
  • I can't see any information about the @sfdcfox answer, can someone share the link if there is any. Jan 11 at 16:03
  • @vishesh Didn't see this until now, but I'm pretty sure PE-based pauses are more or less in real-time.
    – sfdcfox
    Jan 12 at 10:26
  • @AugustoPresotto There's no link, as I can't find docs on it, but I recall that most time-based automations are set on a fifteen minute timer.
    – sfdcfox
    Jan 12 at 10:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .