1

Issue

  • As of 08/17/2022 myself and my Development/QA team has been running into an issue with SF Workbench when using API v55.

  • We are deploying Service Cloud Voice (SCV) Contact Center with features that are in v55

  • The following error is thrown, as soon as you login with your SF credentials

UNKNOWN ERROR: SOAP-ERROR: Parsing WSDL: Couldn't load from 'soapclient/sforce.550.partner.wsdl' : failed to load external entity "soapclient/sforce.550.partner.wsdl"

Related Past Tickets

Version 45 corresponds to Spring '19, it was not available in production on the moment when this question was opened, but should be available now, since all the production organizations should have already migrated to Spring '19.

I'm seeing the same issue. It can be solved by logging out of Workbench entirely and then re-logging in with the API version set to 41. You have to end the session and start over; you can't change the API version in Workbench settings once you get this error.

From the discussion it sounds like the problem might be intermitent and caching related. I'd suggest posting your experience into that discussion. Reverting to API v33.0 in workbench avoids the problem.

Temporary Workaround (Not Ideal)

  • The error goes away when I use API v54, though we are required at this time to use v55

  • Any estimates on how long this usually takes to resolve?

Additional Details && Attachments

Screenshot of Issue in SF Workbench using API v55 SF - Workbench - API v55 - SOAP Error

Ticket Not Related/Not Duplicate

  • SF Workbench - API Version - v55 Not Appearing
    • This question was actually asked by me a month ago, this is a different issue where the dropdown to select API Version in SF Workbench did not have a value of v55 This has been resolved since and was able to select v55 and use the deploy feature as we need without issue
3
  • This question was actually asked by me a month ago, this is a different issue where the dropdown to select API Version in SF Workbench did not have a value of v55 This has been resolved since and was able to select v55 and use the deploy feature as we need without issue However it has recently broken (past couple of days), where I select v55, login with the appropriate SF Org, then it throws the above error SF Workbench - API Version - v55 Not Appearing @identigral Commented Aug 18, 2022 at 16:33
  • Confirm that v55 is still an issue with Workbench. You're right in that it's not an exact duplicate of the previous issue but it's the same root cause - they didn't quite fix it. Complain on github.
    – identigral
    Commented Aug 18, 2022 at 16:43
  • 1
    @identigral With the latest SF Workbench, I am able to now select API v56 without issue Commented Oct 25, 2022 at 16:20

1 Answer 1

1

This has been fixed in the latest version of SF Workbench

  • I am able to use API v56 (Winter '23) for the API Version and click the Login With Salesforce button and enter SF Workbench without any issue

I am NO LONGER ABLE to see the error

UNKNOWN ERROR: SOAP-ERROR: Parsing WSDL: Couldn't load from 'soapclient/sforce.550.partner.wsdl' : failed to load external entity "soapclient/sforce.550.partner.wsdl"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .