0

I am trying to deploy roughly 100 text fields to my production instance, specifically to my Opportunity object.

When trying to deploy or even validate the change I get "unable to obtain exclusive access to this record". I have tried to heavily reduce the deployment field number up until just 5 fields and I am still getting the same error.

Can someone suggest how I can successfully deploy these fields and what the cause might be?

1 Answer 1

1

You, or another admin, made a recent change in your org that is still executing in the background. I don't have a full list of what triggers this behavior, but the point is that your organization is locked from further changes until whatever it was that was triggered finishes executing. You, or the administrator that triggered the background process, will be notified by email when that process is complete. If it's taking a really long time, contact support, as they can look at your organization's status to figure out what's keeping you from deploying. You can also check the Setup Audit Trail to see what that recent change was made.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .