I'm trying to view logs in the Developer Console. Whenever I try and view the log I get an error message.

Failed to load data Log from Salesforce.com: Salesforce automatically deletes system logs 24 hours after they're generated. If the log you had open was less than 24 hours old, someone deleted it. To save logs, select File > Download Log.

It's a brand new log entry and it hasn't been deleted. The log entry had just been created a few seconds before. It happens for all logs. I've tried logs coming from Apex code as well as a simple System.debug('TEST') from the Execute Anonymous windows. The logs aren't even very big. Just a few KB.

I tried creating a new Developer Console workspace and deleting all old logs from the ApexLogs table.

It had been working fine earlier in the day and for the last several months.

EDIT: I noticed that I can open a log entry if I select Open Raw Log from the File menu but just double clicking on the log entry or selecting Open Log give me the error.

  • Have You Tried Turning It Off And On Again? - for your user
    – Raul
    Jul 22, 2022 at 22:07
  • Can you try these steps, Open Dev console--->Workspace--->New Workspace---> Enter a name for the workspace and click OK.
    – Vinay
    Jul 22, 2022 at 22:34
  • @Vinay as I mentioned in my post I did try that. No luck.
    – James
    Jul 22, 2022 at 23:35
  • Delete existing trace and add it again for your user from debug logs via setup menu, then after executing the script from developer console, monitor it in debugs logs. Behavior of developer console is funky sometimes, but have never faces on what you described. Also try again in incognito window if nothing helps, could be caching or some of your browser extensions.
    – Raul
    Jul 23, 2022 at 0:53
  • 2
    This has been an issue all week for us as well - Open Log is broken - Open Raw Log and Download Log both work.
    – Maggie
    Jul 26, 2022 at 16:58

2 Answers 2


We had this same error. Below are the instructions we got from Salesforce:

  1. Login to Workbench and go to REST Explorer
  2. Use the following query in Workbench to get the IDEWorkspace /services/data/v49.0/tooling/query/?q=SELECT id, name from IDEWorkspace ID of IDEWorkspace is "1dexxxxxxxxxxxxxx".
  3. Do GET operation for the found id with following query "/services/data/v49.0/tooling/sobjects/IDEWorkspace/1dexxxxxxxxxxxxxx"
  4. You will see the content of IDEWorkspace
  5. Do DELETE operation on found record.
  6. Re-open Developer Console.
  7. Developer Console should work fine. As we created a new workspace and the old workspace has been deleted. And the slowness will also be removed.
  • It seems like this is basically the same thing was deleting the workspace directly from the Dev Console which didn't work for me. Either way the issue seems to have resolved itself.
    – James
    Jul 30, 2022 at 19:15

Got the same error in 5 of our orgs, 1 Prod 4 Sandboxes. SF support is still trying to puzzle this out but it seems that this is some kind of global issue as clearing the workspace and creating a new one does not help at all.

  • @DavidCheng I think it's a helpful comment. It seems it's a Salesforce issue.
    – James
    Jul 25, 2022 at 17:09
  • 1
    But if being serious, the error is gone from our orgs. Can you try to open debug logs now? Jul 27, 2022 at 8:55
  • As of yesterday it is now working for me.
    – James
    Jul 30, 2022 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .