We have a flow which copies a subset of values from an existing opportunity to create a new record (a renewal opportunity).

It seems to work fine with most Record Types but with one record type ("Water") it fails to process the Create Record action.

The error is This error occurred when the flow tried to create records: MALFORMED_ID: Record Type ID: id value of incorrect type: Water.

What's weird is we are trying to set the RecordTypeId from the existing record:

debug text for Flow

As you can see value is a valid value (it's copied from the existing Opportunity) - it's the correct ID for 'Water' but the flow is refusing to accept it.

  • I find that weird, I remember we had a similar use case, and the Create Record action worked just fine. Does the running user have access to the Water record type? if you go to Advance options in the flow's setup, what option is selected for: How to Run the Flow?
    – McCubo
    Jul 19, 2022 at 15:04
  • error message looks like trying to set a RecordType.Name to an ID field
    – cropredy
    Jul 19, 2022 at 19:13
  • Can you add the screenshot of your flow so that we know how you are setting the recordtypeid? Jul 20, 2022 at 3:29
  • @McCubo yes we ran as admin in the debugger, same error
    – Quango
    Jul 25, 2022 at 8:26

1 Answer 1


I was going to add a screenshot of the flow when I noticed a Flow in the list called "Water - set record and name".

This flow sets the RecordTypeId to Water when a Water Opportunity is created, so it was a different flow triggered by the 'problem' flow which was causing the issue. Doh! Many thanks to all those who replied.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .