3

I'm trying to use the Analytics Download API to get a PNG of my dashboard, but I'm getting a resource not found error.

The command I'm using:

curl https://[my_organization-dev].my.salesforce.com/services/data/v55.0/analytics/download/dashboard/[dashboard_id].png -H "Authorization: Bearer [token]"

The response I'm getting:

[{"errorCode":"NOT_FOUND","message":"The requested resource does not exist"}]%

I'm using the same ID I got from listing recently viewed dashboards, and I can use this ID for other dashboard-related API calls, so I am confident I'm using the correct ID.

I've also tried using this API to download a report png, which didn't work. Just to make sure, I've tried using the dashboard name instead of ID, which also didn't work.

I am using cURL to make requests, which has worked for all the other API calls I've tried so far.

Edit: I'm working on Salesforce Developer Edition as a proof of concept. I've enabled Slack for Salesforce and CRM Analytics in my "organization" and can use other API functions that require this, including other Analytics API functions.
I can download the dashboard image from the dashboard itself, but I'm looking for a way to do it through the API for automation purposes.

Using this guide, I ensured that my sandbox organization is using API version 55.0, so this shouldn't be an issue.

5
  • 1
    Do you have Slack for Salesforce and CRM Analytics for Slack enabled in your org? See doc
    – identigral
    Jul 10, 2022 at 8:17
  • 1
    Could you please add few more details here. I believe you can download the dashboard image through out-of-box- functionality?
    – Pavan tej
    Jul 10, 2022 at 11:10
  • Thank you for the feedback, I've added some more information to the question, and addressed both those. Hopefully I'm not missing anything important!
    – Cyare
    Jul 11, 2022 at 18:19
  • @Cyare did you ever figure anything out on this? Hitting the same error when trying to download a dashboard PNG.
    – cdwyer
    Mar 3, 2023 at 23:19
  • 1
    @cdwyer Unfortunately, I wasn't able to figure it out.
    – Cyare
    Mar 5, 2023 at 19:32

2 Answers 2

0

To download data from widgets and lenses using the CRM Analytics user interface, Download CRM Analytics Data user permission needs to be granted. https://help.salesforce.com/s/articleView?id=sf.bi_download.htm&type=5

It is worth it to check the experience from UI vs API.

1
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – identigral
    Apr 25, 2023 at 17:18
0

I was having a similar problem and then noticed that the documentation says domain/analytics/download/dashboard/0FKB0000000xxxxxxx.pdf

I removed "services/data/v55.0/" from mine and now it works! So hopefully if you use https://[my_organization-dev].my.salesforce.com/analytics/download/dashboard/[dashboard_id].png, yours will work too.

[Update] I also had to pass a session id to my request

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .