I am getting following error while deploying code from VSCode.

Error deploying or retrieving source: The file or directory that you tried to deploy or retrieve isn't in a package directory that's specified in your sfdx-project.json file. Add this location to your "packageDirectories" value, or deploy or retrieve a different file or directory. For details about sfdx-project.json, see: https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_ws_config.htm

Retrieving of code into VSCode seems to work fine but deployment throws this error.

Here is what my sfdx-project.json looks like

      "packageDirectories": [
          "path": "force-app",
          "default": true
      "name": "XXXXXX2022",
      "namespace": "",
      "sfdcLoginUrl": "https://test.salesforce.com",
      "sourceApiVersion": "55.0"

It was working fine till last week, suddenly today i seem to get this error. Anybody having similar issue?

  • 1
    Similar question thread is here - salesforce.stackexchange.com/questions/380221/…
    – Ysr Shk
    Commented Jul 8, 2022 at 12:58
  • What are you trying to deploy? Commented Jul 8, 2022 at 13:21
  • 2
    @PhilW Looks like an issue with the latest release. Others have reported the same on githib
    – Prady
    Commented Jul 8, 2022 at 14:02
  • 1
    See github.com/forcedotcom/salesforcedx-vscode/issues/4261 Commented Jul 8, 2022 at 14:02
  • 1
    @PhilW downgrade worked
    – Prady
    Commented Jul 8, 2022 at 14:07

2 Answers 2


There is an issue with the most recent Salesforce CLI Integration Extension for VS Code on Windows (v55.4.0)

To resolve, go to your extensions, go to Salesforce CLI Integration, click the drop down next to Uninstall, and click "Install another version". Install the previous version (55.3.0)


As a fix, v55.4.1 of the Salesforce Extension for VS Code has been published. See the release notes here: https://github.com/forcedotcom/salesforcedx-vscode/releases/tag/v55.4.1

  • Thanks for keeping us posted
    – Prady
    Commented Jul 28, 2022 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .