1

I am attempting to update an LWC component using VSCode. I am able to successfully create the LWC if it currently does not exist in the sandbox - but any effort to update it fails with the following errors

What is interesting about this is if I manually delete the component, it will allow me to create a new one - but there is no discernible error associated with the deployment which is making troubleshooting difficult.

EDIT: Can successfully edit all other files in the directory. In particular there is a controller going over with this LWC and it works fine - just not the LWC component

Have tried:

  • Updating SFDX
  • Refreshing Sandbox
  • Changing API version

Any help would be appreciated

VSCode

enter image description here

Deployment Settings:

enter image description here

3
  • Does tail ~/.sfdx/sfdx.log show anything more?
    – sfdcfox
    Commented Jul 7, 2022 at 1:43
  • I've got two error codes: ENOENT and "ERR_INVALID_ARG_TYPE". Invalid argument doesn't make sense as it deploys on create, but not on edit
    – jlawm
    Commented Jul 7, 2022 at 1:53
  • Should mention there are no 'Problems' under the Problems tab
    – jlawm
    Commented Jul 7, 2022 at 1:57

1 Answer 1

0

Solved the problem. Meta file contained <analytics_Dashboard> - once removed, the updates deploy successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .