As of today (6/7/2022) the sfdx force:source:push command started failing after scratch org creation as part of the deployment script we're using in our pipeline.

It throws the following errors back:

enter image description here

It's happening on every push and the picklist is almost always a different one. Is there someone else getting the Duplicate picklist value error back as well out of nowhere? And ideally, did you find how to fix this? So far I wasn't really successful as the same metadata worked fine yesterday.

7/7/2022 Update - the source is pushed as expected again, both locally and as part of the deployment pipeline

  • Did you by any chance rename a bunch of picklist API values while leaving the label intact? Jul 6 at 15:40
  • No, everything is the same as it was when it still worked yesterday. Pushing from the same branch which was not touched...
    – Michal V
    Jul 6 at 15:41
  • Just wondering if it might be a global issue, so wondering if someone else is having the same issue as of today.
    – Michal V
    Jul 6 at 15:43
  • Did you update your sfdx CLI version since yesterday (or is that something your CI pipeline always does)? Have you tried creating a new scratch org today, manually, and pushing?
    – Phil W
    Jul 6 at 16:02

1 Answer 1


I created a ticket on the SFDX CLI repo here. Adding a comment may help to increase visibility: https://github.com/forcedotcom/cli/issues/1605

Here are additional links to places this issue is being discussed: https://trailhead.salesforce.com/trailblazer-community/feed/0D54S00000HEAATSA5 https://trailhead.salesforce.com/trailblazer-community/feed/0D54S00000HEACASA5 https://trailhead.salesforce.com/trailblazer-community/feed/0D54S00000HEAGrSAP


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.