2

We are using below script to install sfdx plugins on top of Jenkins via below docker file.

FROM jenkins/jenkins:2.263.3
USER root

RUN mkdir /.cache /.sf

RUN chown jenkins.jenkins /.cache -R

RUN chown jenkins.jenkins /.sf -R

RUN chmod 757 /.cache /.sf -R

RUN apt-get update && apt-get install -y git ant xmlstarlet xz-utils && \
wget https://developer.salesforce.com/media/salesforce-cli/sfdx/channels/stable/sfdx-linux-x64.tar.xz && \
tar xJf sfdx-linux-x64.tar.xz --strip-components 1
RUN sfdx --version

RUN echo y | sfdx plugins:install sfdx-git-delta

RUN sfdx plugins

USER jenkins

However, the plugins are not getting installed. There are no installation errors as well.

Below is the section of build from terminal: enter image description here

Also, this is not an issue with sgd plugin. I tried installing other plugins as well, with same result.

Any help is appreciated as we are trying to fix it from last week.

1 Answer 1

0

Compared to my docker where CLI plugins get installed successfully, could it be that you are missing single quotes around the 'y'?

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .