0

As in the title, I've encountered a problem with the .sfdx/ folder in my repo. After cloning the project it sees some local changes in the typings/lwc and typings/tools folder. .sfdx/ folder is ofc in the .gitignore.

enter image description here

I can discard most of the changes except the apex.db. In this case I'm getting this error: enter image description here

I've tried killing Java process in the background etc. but nothing worked. Only cloning project once again allowed me to change branches but this ofc isn't the solution.

Does anyone have an idea what's the issue and how to solve this one?

4
  • There may be a background process that is still using it, might want to restart vscode otherwise your computer as well and try again?
    – Raul
    Jun 23 at 9:26
  • @Raul done that, sadly it's happening every time when the branch is changed so even killing the java process as this is the one in the background every time is not the best solution sadly Jun 23 at 9:36
  • Have you tried soft reset in GIT? and also restarting your computer?
    – Raul
    Jun 23 at 9:40
  • yes, all of it - nothing worked Jun 23 at 9:44

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.