10

A Flow metadata deployment to a Summer 22 (v55.0) org causes an error:

{!FlowScreenFieldName} (Screen Component) - Because the "{!FlowScreenFieldName}" screen field 
on the "{!FlowScreen}" screen is a section, the regionContainerType is required.

What is wrong with Flow metadata if it is fully deployable to previous versions orgs and how to fix that?

1
  • The easiest fix to this issue would be to re-download the flow metadata using 55.0 API version and then it will be downloaded with all tags and structures as per that API version and you can deploy it further to other org again without getting error.
    – VarunC
    Jun 21, 2022 at 18:16

3 Answers 3

10

The regionContainerType field of the FlowScreenField metadata component was introduced in API version 55.0. Although it is not documented, when the component type is a Section this field is required.

To fix that simply manually add regionContainerType element with SectionWithoutHeader value to a Flow metadata file:

<?xml version="1.0" encoding="UTF-8"?>
<Flow xmlns="http://soap.sforce.com/2006/04/metadata" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  ...
  <screens>
    <name>FlowScreenName</name>
    <label>FlowScreen Label</label>
    <fields>
      <name>FlowScreenName_SectionN</name>
      <regionContainerType>SectionWithoutHeader</regionContainerType>
      ...
    <fields>
  </screens> 
</Flow>

The easier way would be retrieving Flow instances from updated to Summer 22 sandbox instances if the metadata in the project repository matches the last deployed metadata. After that, all the flow screen sections will be automatically updated with <regionContainerType>SectionWithoutHeader</regionContainerType> element.

2

This seems to be a bug in how the metadata is retrieved. For example, in VS Code if you retrieve the flow metadata via the Org Browser the value will not appear in the metadata. However, if you use the explorer or command line to pull the metadata the value will be retrieved. This has worked for us and allowed us to continue deployment.

1
  • 1
    Be sure to check your version of the flow components in the package manifest used to retrieve the metadata (ie. may need to add <version>56.0</version>). Oct 18, 2022 at 16:05
1

I had a similar issue: deploying a flow (metadata 57.0) to the spring 23 sandbox (v.55) and still got the strange error message "Property 'regionContainerType' not valid in version 53.0". In that case, I had to remove the tag

        <regionContainerType>SectionWithoutHeader</regionContainerType>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .