I currently use Gearset to deploy to our Bitbucket repo. We don't quite have a perfect dev > branch > deploy process yet and some changes get made directly in production. This causes 2 sources of truth. Our git repo, and metadata in production.

To handle this, I have an automatic job that does a commit from Prod to a "ProdToMain" branch that we periodically merge back into main. This is great and handles a lot of little config changes made directly in prod.

I'm seeing this weird situation where a handful of our layout xml files are including +12 new lines of empty space each commit.

enter image description here

Each time I merge our "ProdToMain" branch into main, the next commit to our "ProdToMain" branch adds a new layer of blank spaces.

Any ideas here? It's not impacting functionality or anything, but this could easily get out of control over time. I don't think our dev time should be spent deleting empty lines out of files regularly.

  • 4
    This sounds like a tooling problem. Have you tried contacting GearSet directly? Aside from that, if possible, you could set up a pre-commit hook to run Prettier or some other XML formatter to eliminate the dead space.
    – sfdcfox
    Jun 15 at 18:00
  • Thanks sfdcfox. You re-affirmed my thoughts. I'm opening a ticket with Gearset as well, just thought I'd try multiple fronts. I'll look into a pre-commit hook as well. That would be useful. I'll update the ticket as I learn more around this. Jun 15 at 19:03
  • In a recent update a couple days ago, I saw an update regarding not leaving whitespace where XML tags were removed due to problem analyzers - I presume this might've been related to that? Either way, gearset chat is always the best option - very responsive. Jun 25 at 22:47
  • 1
    Thanks Kris. I'm actually the one that submitted the bug with Gearset and worked with them on resolving the issue. I had been planning to update this ticket when I got something definitive back from them. Looks like you saw the notes before I was able to update this question! Jun 27 at 13:47

1 Answer 1


I contacted Gearset per sfdcfox suggestion and it did end up being something on their end.

They had a problem analyzer that removed IsotopeSubscription exclude buttons due to reports of it causing errors in Spring '22. Unfortunately, it left blank lines behind in its place.

2 fixes were implemented to resolve this:

  • don't leave blank lines behind when removing the tag.
  • don't remove the tag in Summer '22 as the issue with the tag has been resolved.

The fixes do not remove the blank lines previously added to the files, but that is easy enough to clean up.

Not the answer you're looking for? Browse other questions tagged or ask your own question.