I am trying to push the force-app directory metadata into a scratch org,I am getting below error when I run cci task run dx_push --extra -f

ci task run dx_push --extra -f  
Error: no such option: --extra 
Run this command for more information about debugging errors: cci error --help

Basically I am trying to force (overwrite) to push the source to a scratch org.

As per the documentation ,We can pass the extra arguments


Description: Uses sfdx to push the force-app directory metadata into a scratch org
Class: cumulusci.tasks.sfdx.SFDXOrgTask
Command Syntax
$ cci task run dx_push
--command COMMAND
The full command to run with the sfdx cli.
Default: force:source:push
--extra EXTRA
Append additional options to the command


1 Answer 1


I just tested this and found it worked fine with CumulusCI 3.60.0 (the latest version). Please make sure you're up to date.

Here's the log:

sea-dreamin main $ cci task run dx_push --extra -f --org dev
[06/10/22 21:18:49] Creating scratch org with command: sfdx force:org:create  -f orgs/dev.json -w 120 -n --durationdays 7 -a None__dev [email protected]         
[06/10/22 21:19:26] Successfully created scratch org: 00D17000000hQbtEAE, username: [email protected]                                                         
                    Generating scratch org user password with command: sfdx force:user:password:generate -u [email protected]                                 
[06/10/22 21:19:28] Getting org info from Salesforce CLI for [email protected]                                                                                
[06/10/22 21:19:30] Org info updated, writing to keychain                                                                                                                 
                    Beginning task: SFDXOrgTask                                                                                                                           
                    As user: [email protected]                                                                                                                
                    In org: 00D17000000hQbt                                                                                                                               
                    Running command: sfdx force:source:push -f -u [email protected]                                                                           

I tested with and without quotes around the -f argument and both translated into the correct SFDX command (shown on the last line above).

  • Thanks David, This worked after upgrading CumulusCI to 3.60.0 Jun 11, 2022 at 8:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .