1

I am trying to deploy my chat button with routing type omni-channel using SFDX and this error occurred:

You must select at least one skill.

what do I need to make?

0

5 Answers 5

1

I WAS ABLE TO DEPLOY CHAT BUTTON!!!

I was receiving the same message that you shared: You must select at least one skill.

To solve this you need to leave the language on Chat Buttons & Invitations as Blank

You do not need to config skills, or activate any skills config.

liveChatAgentConfigs

<?xml version="1.0" encoding="UTF-8"?>
<LiveChatAgentConfig xmlns="http://soap.sforce.com/2006/04/metadata">
    <assignments>
        <profiles>
            <profile>admin</profile>
        </profiles>
    </assignments>
    <disableTransferConferenceGreeting>false</disableTransferConferenceGreeting>
    <enableAgentFileTransfer>true</enableAgentFileTransfer>
    <enableAgentSneakPeek>true</enableAgentSneakPeek>
    <enableAssistanceFlag>false</enableAssistanceFlag>
    <enableAutoAwayOnDecline>false</enableAutoAwayOnDecline>
    <enableAutoAwayOnPushTimeout>false</enableAutoAwayOnPushTimeout>
    <enableChatConferencing>false</enableChatConferencing>
    <enableChatMonitoring>true</enableChatMonitoring>
    <enableChatTransferToAgent>true</enableChatTransferToAgent>
    <enableChatTransferToButton>true</enableChatTransferToButton>
    <enableChatTransferToSkill>false</enableChatTransferToSkill>
    <enableLogoutSound>false</enableLogoutSound>
    <enableNotifications>true</enableNotifications>
    <enableRequestSound>true</enableRequestSound>
    <enableSneakPeek>false</enableSneakPeek>
    <enableVisitorBlocking>false</enableVisitorBlocking>
    <enableWhisperMessage>true</enableWhisperMessage>
    <label>INSERT YOURS</label>
    <supervisorDefaultButtonFilter>AgentsBemol</supervisorDefaultButtonFilter>
    <transferableButtons>
        <button>INSERT YOURS</button>
    </transferableButtons>
</LiveChatAgentConfig>

liveChatButtons

<?xml version="1.0" encoding="UTF-8"?>
<LiveChatButton xmlns="http://soap.sforce.com/2006/04/metadata" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <deployments/>
    <enableQueue>true</enableQueue>
    <isActive>true</isActive>
    <label>INSERT YOURS</label>
    <optionsCustomRoutingIsEnabled>false</optionsCustomRoutingIsEnabled>
    <optionsHasChasitorIdleTimeout>false</optionsHasChasitorIdleTimeout>
    <optionsHasInviteAfterAccept>false</optionsHasInviteAfterAccept>
    <optionsHasInviteAfterReject>false</optionsHasInviteAfterReject>
    <optionsHasRerouteDeclinedRequest>false</optionsHasRerouteDeclinedRequest>
    <optionsIsAutoAccept>false</optionsIsAutoAccept>
    <optionsIsInviteAutoRemove>false</optionsIsInviteAutoRemove>
    <overallQueueLength>255</overallQueueLength>
    <routingType xsi:nil="true"/>
    <type>Standard</type>
</LiveChatButton>

enter image description here

enter image description here

enter image description here

enter image description here

Check my comment!

https://developer.salesforce.com/forums/?id=9062I000000g9HUQAY

2

As mentioned in the doc,

Chats routed with Omni-Channel aren’t supported in the Metadata API.

They can’t be retrieved or deployed with Metadata API, and changes to them must be made manually in each of your organizations. This is currently a limitation of the platform.

1
  • 1
    So, in the doc say "are not supported in the metadata API" but I am using soap API... May 31, 2022 at 13:25
2

I solve my problem with a workaround. The workaround is to change the route type from Omni-Channel to Choice with a skill and manually change it back after deployment.

0

It is not supported by the Metadata API.

0
0

The ChatBot's channel provider name is not configured for the LiveChatButton entity.

I solved this problem by copying all the settings involving the chatbot. I had to copy the roting configuration, queues, Live Chat buttons and even the Bot.

On my first attempts, the error below appeared.

The ChatBot's channel provider name is not configured for the LiveChatButton entity.

I believe this is because you do not have a LiveChatButton with the same configuration as you have in the Homologation Org.

I could not validate the ChatButton along with all the other components, so I created a new one and configured it.

You also need to remove all users from the bot and leave the Basic ChatBot User Option Selected, then when they are in the production org you can configure the user you need.

In short, remove LiveChatButton from the external change set and create the same configuration in the production organization.


PT.BR

O nome do provedor de canal do ChatBot não está configurado para a entidade LiveChatButton.

Resolvi esse problema copiando todas as configurações que envolvem o chatBot. Tive que copiar a configuração de roting, filas, botões do Live Chat e até mesmo o Bot.

Em minhas primeiras tentativas, apareceu o erro abaixo.

O nome do provedor de canal do ChatBot não está configurado para a entidade LiveChatButton.

Acredito que isso se deve ao fato de você não ter um LiveChatButton com a mesma configuração que tem na Homologation Org.

Não consegui validar o ChatButton junto com todos os outros componentes, então criei um novo e o configurei.

Também é necessário retirar todos os usuários do ChatBot e deixar a opção de Usuário do ChatBot básico selecionada; depois, quando eles estiverem na organização de produção, você poderá configurar o usuário necessário.

Em suma, retire o LiveChatButton do conjunto de alterações externas e crie a mesma configuração na organização de produção.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .