1

I recently did a new install of VSCode and SFDX CLI on a new Macbook. So versions are recent. I have updated SFDX since this error but it still exists.

sfdx-cli/7.152.0 darwin-x64 node-v16.15.0

  • What I am doing:

I am deploying an Apex Class by Right Clicking on the file in the editor and choosing "Deploy this source to org", I have also used a terminal command to deploy source.

  • What is happening:

Typical errors are being returned into the Problem Log.

  • What is the issue:

However clicking on those errors I get taken to a file that does not exist and get this error (see pics) - enter image description here

"The editor could not be opened because the file was not found" enter image description here

Take Note of 1. The Breadcrumbs and 2. in problems the Class file and exyension a followed by a root path "/" then force-app

see the second error is from PMD it is responding properly and the problem is linked to the correct file, note the start of each path "/" vs "". enter image description here

How can I fix this Path issue, it seems to be a bug but maybe it is a configuration. I cannot find any other complaints about it.

1 Answer 1

1

This issue was solved in a recent release

https://github.com/forcedotcom/salesforcedx-vscode/pull/4246 https://github.com/forcedotcom/salesforcedx-vscode/pull/4241

1
  • 1
    Welcome to Salesforce SE! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – identigral
    Commented Aug 3, 2022 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .