0

When we try to create a second generation package using CumulusCi we get stuck on the initializing part. This use to work fine but stopped working all at once. The steps to recreate is below. We also has the remove metadata component from package feature add to are account shortly before this issue arose.

To recreate:

  1. cci task run create_package_version --org release --package_type Managed --version_type minor --ancestor_id 04t4******
  2. It will continue to go on indefinitely with the output looking like this
    [05/11/22 10:16:47] Increased polling interval to 204 seconds                                                                                                                                                                       
                        [Initializing]                                                                                                                                                                                                  
    [05/11/22 10:20:11] [Initializing]                                                                                                                                                                                                  
    [05/11/22 10:23:35] [Initializing]   
    

We have also tried to run this using sfdx force:package:version:create with similar results

1 Answer 1

1

Unfortunately, the fact that both clients (cci and sfdx) show the same infinite polling behavior indicates that this issue is inside the platform. Neither the CumulusCI team (my team) nor the SFDX team is likely to be able to help you, because the issue is in a layer below those tools.

I would recommend opening a support case. You'll need internal troubleshooting to get to the bottom of what's causing your Dev Hub to queue these uploads forever.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .