3

When I issue a force:source:push on a freshly provisioned scratch org, it gives me an initial feeling that it's working but then says there's a TimeoutOverflowWarning

*** Pushing with REST API v53.0 ***
(node:28380) TimeoutOverflowWarning: 5454000000 does not fit into a 32-bit signed integer.
Timeout duration was set to 1.
(Use `node --trace-warnings ...` to show where the warning was created)

I've updated my SFDX - 7.149.1 and that didn't help
I've updated my Node.JS - v16.15.0 and that didn't help
I've tried setting this to true and false, but no difference sfdx config:set restDeploy=true

Lo and behold.. if I go watch the deployment status page in the setup of my scratch org, I can actually watch the progress occur there.. and it succeeds! (I didn't even know it was doing ANYTHING)

But how is my local workstation's source tracking going to be properly notified?

screenshot of Deployment Status with inset of CLI shell

7
  • The error suggests the deployment took over 1500 hours to deploy. Assuming that's not true, you might want to report this as a bug to the SFDX team.
    – sfdcfox
    May 6, 2022 at 18:02
  • Very interesting, @sfdcfox .. the error is reported in my terminal after just 20 seconds.. and if I switch to the browser, the Deployment Status circle chews through the 905 items lickity-split (faster than I ever recalled, compared to a few months ago)
    – bkwdesign
    May 6, 2022 at 18:04
  • This seems like a bug so you might have luck if you report as a bug with sfdx team as @sfdcfox suggested.
    – metasync
    May 8, 2022 at 3:30
  • I had this same problem with sfdx 1.500, rollback to 1.149.1 solved the problem May 17, 2022 at 13:38
  • @JoaoVitorino - thanks for the tip. In my bum scenario, I'm on 7.149.1 - I'm not sure I'm reading your version right
    – bkwdesign
    May 18, 2022 at 19:30

0

You must log in to answer this question.

Browse other questions tagged .