1

We are implementing in-app messaging and we are facing into a very weird behaviour:

We developed and tested the arrive of the In-app on a phone (iPhone12 mini OS 15.2.1 used for the developing phase) and later we released the .ipa file on AppCenter in order to allow testers to download and test the functionality.

In the following testing session even if we tried with the same contact key/same application (with same signing certificate) we didn't manage to receive the In-App on the testers phone (we tried two different phones iPhone 12mini OS 15.2, iPhone 13 mini), but on the phone used for the developing phase we still continue to receive the In-App even if we uninstall de developing application and install the one signed and shared on AppCenter.

Some more information:

  • CocoaPods used --> pod 'MarketingCloudSDK', '= 8.0.6'
  • Notifications are enabled

Have you please any ideas to help us to solve this issue?

1
  • 3
    Speculation: this is almost certainly an audience list problem, but you can open a support case. If they tell you to come here, tell them they are wrong and at mention me.
    – Bill Mote
    May 4, 2022 at 12:11

0

You must log in to answer this question.

Browse other questions tagged .