I have a record triggered flow after update, which uses a Send Email action to send an email to the email address specified in the Account record.

While it works fine when the email address is outlook or our company domain based on outlook as well, emails are not being received by gmail addresses. I have checked my gmail configurations and also tried with other emails from colleagues, but they are not going to SPAM nor being routed by filter rules.

Additionally, if I test the very same email address from /lightning/setup/TestEmailDeliverability/home emails are received properly.

What can be the reason for certain email addresses not receiving these emails?

  • Can you try checking Setup-->Quick Find-->Process Automation Settings-->Update "Automated Process User Email Address" with Organization-Wide Email Addresses.
    – Vinay
    Commented Apr 23, 2022 at 10:49
  • I just tried, unfortunately no luck so far Commented Apr 23, 2022 at 11:01
  • Can you check your email logs if the emails are being triggered there or is there any error on deliverability of emails Commented Apr 23, 2022 at 11:08
  • Check email logs and see if SPF, DKIM, and DMARC are properly configured as per steps mentioned in doc also check with your internal IT team on this.
    – Vinay
    Commented Apr 23, 2022 at 21:59

2 Answers 2


I figured out that, If the sender was using one of our company domain email addresses, emails were not received in gmail and were spam in outlook. However they are received properly if the sender is an OrgWideEmailAddress (specified in the Send Email actions in the flow, in the Sender Type attribute) based on gmail.

  • Would you please let me know, how do you add OrgWideEmailAddress in Sender Type? I tried everything I knew, but it didn't show up as a value/variable.
    – Babak
    Commented Aug 11, 2022 at 19:49

I had the same problem and finally found a solution. The method you described was also able to solve the problem. However, I realized that it's virtually impossible to get SFDC users to uniformly use Gmail to send mail.

After thinking more about why it wasn't working, I realized that there was an issue with the reliability of the addresses that SFDC was sending.

Since SFDC and Google often collaborate with each other, it didn't seem like a reliability issue with SFDC itself, and when I dug deeper into my email settings, I realized what the problem was.

I was able to discover that following standard email security mechanisms could improve reliability, and this allowed me to send mail without using Gmail.

It's been a while since this post was published, but it's still at the top of the search, so hopefully others will be able to resolve this issue as well.

Setup -> Deliverability -> Check under the "Email Security Compliance (Emails from Salesforce or Email Relay Only)"

Check "Enable compliance with standard email security mechanisms" and "Enable Sender ID compliance"Select these checkboxes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .