0

I have a Lightning Web Component that is using the import {getRecord , getFieldValues } and then displaying for clients in customer community within a LWC; however, the field values are not populating. Under the required document list field, there is a lot of text in a Rich text field on the record. I am seeing it from an admin view in Salesforce/experience cloud/lwc but the client cannot see the field text.

I'm thinking there is some permission issue, but I have checked the site settings in digital exp > settings (it's readable here for guests)

I have checked the profile settings, the object fields are readable here as well.

In the banner bar it is populating the correct record name from the recordId (I have blacked it out) so I would presume the recordID is getting passed over correctly. The banner bar is not a part of the LWC though.

record in experience cloud for client

4
  • Could you check the network tab in DevTools to see if the data is being pull from SF or any error ? Apr 7 at 14:53
  • @Bartheleway I was just looking at this, I don't see any errors, I also can confirm that one of the request headers I see the correct record id in the referer field Apr 7 at 14:55
  • In the response of the request you talked about, do you see all the needed data or is it incomplete ? Apr 8 at 14:49
  • @Bartheleway Sorry for the delayed response. I have it working now. For anyone coming across this in the future, I had to do two things. I needed to update the sharing settings to be private (allow the clients to only view their records) and I had to update the sharing settings in the workspace admin settings so that they had read/write ability. Apr 11 at 14:06

1 Answer 1

0

The problem may be the sharing settings in the org. While internal access (e.g. a normal full license user) defaults to public, external access (e.g. an Experience Cloud user) defaults to private in new orgs:

sharing settings screen shot

Review these settings, and try changing the external access to the appropriate public option.

5
  • Thanks for this, I did make the update, but this did not solve my issue, unfortunately. Apr 7 at 15:18
  • To add on to this, I want to keep this private, because each User should only be able to see the records they are related to. If I make this public, they can see everyone else's records Apr 7 at 15:31
  • Hi @User_11223344, And you have checked the profile/permission set access at the field level too?
    – Keith C
    Apr 7 at 15:32
  • Yes, I have the custom profile and permission set both being able to read all fields Apr 7 at 15:37
  • Ok, I went back to check, I had one box unchecked, which was the owner - I clicked it to make sure all were checked, and now the field is populating. This is baffling as nothing in my LWC is using the Owner field. Apr 7 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.