0

So, the issue is that I have configured the Reply Mail Management (RMM). However, when I tried to send a reply email, it showed this error. enter image description here

Questions:

  1. I believe it's the MX records that haven't been set up for the domain/subdomain, hence appeared this error. But what else could be the problem if I may ask?
  2. As I did some research, knowing that the client must have the DNS configured, by adding 4 NS entries to domain/subdomain (meaning to delegate a domain/subdomain to the Salesforce Marketing Cloud name servers)

However, I'm not quite sure what is exactly to be changed here, my assumption is:

// BU is for differentiating between different BUs
NS: BU.company.com IN NS ns1.exacttarget.com 
NS: BU.company.com IN NS ns2.exacttarget.com
NS: BU.company.com IN NS ns3.exacttarget.com 
NS: BU.company.com IN NS ns4.exacttarget.com 

MX (S10): BU.company.com > reply.s10.exacttarget.com 
MX (S10): reply.BU.company.com > reply.s10.exacttarget.com

What are the differences between the two lines of the MX records, I'm not quite sure.

Thank you in advance!

1 Answer 1

0

The DNS records you are showing there are meant for delegating your SAP domain to the DNS servers of Salesforce:

// BU is for differentiating between different BUs
NS: BU.company.com IN NS ns1.exacttarget.com 
NS: BU.company.com IN NS ns2.exacttarget.com
NS: BU.company.com IN NS ns3.exacttarget.com 
NS: BU.company.com IN NS ns4.exacttarget.com 

Once these records are in place, Salesforce is responsible for managing all of the DNS entries (including MX records). However, if you haven't asked for RMM being enabled when populating the SAP request form, the MX records might not be in place yet. You should reach out to the support to enable them. Setting up BOTH NS and MX records in your own DNS configuration is not needed.

If the screenshot presented in your question (containing the Address not found error) is an actual one, the email domain looks quite short to me. This could indicate, that in addition to your SAP domain (which is a subdomain to company.com) you also have a private domain in place for your company.com domain. This allows you to send emails from SFMC using your actual company domain as sender. But, since you already have existing MX records pointing to your own email server (Exchange or similar) you can't also have RMM in place.

An approach for using your top level domain (company.com) as a sender domain will require you to disable RMM, and have the replies going directly to [email protected] - bypassing the RMM altogether. There is no way that RMM and using your top domain for Private Domain can coexist.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .