0

When I deploy code it takes forever. I get a completed progress bar within seconds.

trr sfdx force:source:deploy --sourcepath /Users/mark/projects/trr/force-app/main/default/classes                 
*** Deploying v52.0 metadata with SOAP API v53.0 connection ***
Deploy ID: 0AfC1000000p5DlKAI
DEPLOY PROGRESS | ████████████████████████████████████████ | 6/6 Components

But then it takes 5-10 minutes for the process to finish show me this:

=== Deployed Source
FULL NAME              TYPE       PROJECT PATH
─────────────────────  ─────────  ─────────────────────────────────────────────────────────────────
LeadTriggerTest        ApexClass  force-app/main/default/classes/LeadTriggerTest.cls
LeadTriggerTest        ApexClass  force-app/main/default/classes/LeadTriggerTest.cls-meta.xml
LeadTriggerTest2       ApexClass  force-app/main/default/classes/LeadTriggerTest2.cls
LeadTriggerTest2       ApexClass  force-app/main/default/classes/LeadTriggerTest2.cls-meta.xml
LeadTriggerTest3       ApexClass  force-app/main/default/classes/LeadTriggerTest3.cls
LeadTriggerTest3       ApexClass  force-app/main/default/classes/LeadTriggerTest3.cls-meta.xml
LeadTriggerTest4       ApexClass  force-app/main/default/classes/LeadTriggerTest4.cls
LeadTriggerTest4       ApexClass  force-app/main/default/classes/LeadTriggerTest4.cls-meta.xml
TriggerManagerHandler  ApexClass  force-app/main/default/classes/TriggerManagerHandler.cls
TriggerManagerHandler  ApexClass  force-app/main/default/classes/TriggerManagerHandler.cls-meta.xml
leadTriggerHandler     ApexClass  force-app/main/default/classes/leadTriggerHandler.cls
leadTriggerHandler     ApexClass  force-app/main/default/classes/leadTriggerHandler.cls-meta.xml

For what it's worth, I'm running on a Mac.

Has anyone else experienced this? Any solution ideas? This doesn't happen all the time. Deploys start off fast, but get slower and slower as time goes on.

6
  • 2
    possible due to the source tracking, which is done after deployment.
    – glls
    Commented Feb 4, 2022 at 17:38
  • thanks @glls, but I have source tracking turned off. Commented Feb 4, 2022 at 18:47
  • 1
    today even our org faced this around afternoon (IST), but now its working fine. It took around 46 minutes to retrieve one flow, tried with ANT migration tool, but same result. Commented Feb 4, 2022 at 19:18
  • Nagendra Singh - does this issue happen frequently? Commented Feb 4, 2022 at 20:08
  • 3
    Check the status of your instance server. Performance degradation were reported on some instances yesterday, e.g CS174
    – Shamina
    Commented Feb 5, 2022 at 19:50

0

You must log in to answer this question.

Browse other questions tagged .