4

For the last week I was unable to work with scratch orgs on multiple computers, multiple networks and DevHubs. Simply because I am not able to open the always successfully created scratch orgs.

No matter the method. Be it:

  • sfdx force:org:open
  • or getting the URL directly from the CLI

When calling sfdx force:org:open I always see:

Opening org 00D1x0000002UvzEAE as user [email protected] Waiting to resolve the Lightning Experience-enabled custom domain...... done ERROR running force:org:open: The client has timed out. 15:56:38.152 sfdx force:org:open ended with exit code 1

I tried all of the below without any improvement

  1. Different Computer
  2. Different Network
  3. Switch my Macs DNS from Default to Google 8:8:8:8
  4. Upgrade CLI to latest
  5. Unistall CLI and install Current
  6. Use multiple DevHubs

BUT: when I use a different project everything works like a charm.

11
  • Have you tried looking at a network trace with (for example) Wireshark? Should yield clues. If it's a DNS issue, you can then try to narrow it down and perform the same operation via a shell command without sfdx.
    – identigral
    Jan 28, 2022 at 16:30
  • 1
    What happens if you switch to a different Dev Hub user?
    – Phil W
    Jan 28, 2022 at 16:39
  • @identigral I don't know how to do any of this. Even the URL that I get from sfdx commands doesn't open manually. Jan 29, 2022 at 15:21
  • @PhilW You mean a second admin user in the same DevHub org? Didn't try that. Why should that help? What I tried was another DevHub org. Jan 29, 2022 at 15:22
  • The funny thing is that it seems to be Project dependant. Another SFDX project works like a charm. Jan 29, 2022 at 15:26

5 Answers 5

5

Right now (20 June 2022), I'm getting the same error.

I don't think it's the same problem as you were getting Robert, but if people are googling for the same error message, then this is a solution they can use...

The CLI team say:

Seems enhanced domains is being enabled automatically in new sboxes, we got a fix for this but in the meantime you can get the url from org:display

https://github.com/forcedotcom/cli/issues/1556#issuecomment-1155268803

The quick version of the workaround (also from that GitHub issue) is:

macOS:

open $(sfdx force:org:display -u <sandbox-username> --json | jq -r '.result.instanceUrl')

linux:

xdg-open $(sfdx force:org:display -u <sandbox-username> --json | jq -r '.result.instanceUrl')

Obviously, you need jq to do that, but jq is great anyway.

2

This is what worked for me:

sfdx force:user:password:generate --targetusername $youralias

make a note of the new password, then

sfdx force:user:display -u $youralias

In your browser go to the displayed Login Url and log in using the generated password and the username.

To then allow logging in through sfdx you should enable custom domain in the org (You may need to go to Setup -> Release updates to complete this step)

2

With this, I get the url and pasting that manually to the browser opens the org.

sfdx force:org:open -r
1

A little bit of this.. a little bit of that:

open $(sfdx force:org:open -r | rev | cut -d " " -f1 | rev)

2
  • Could you elaborate a bit on what this does? Dec 31, 2022 at 9:24
  • 1
    Sure. Aiden suggested using the open command and Damecek suggested using sfdx force:org:open -r which returns a message that ends with the org url. Hence the title. The piping is simply extracting the url from the returned message: 1. reverse the message so that the url is at the start of the string 2. cut the message using " " delimiter 3. select the first delimited item (the url) 4. the url is backwards so needs to be reversed again
    – ShOObz
    Jan 3, 2023 at 15:22
1

In instances where sfdx force:org:open -u <org-alias> is resulting in the process hanging with a:

Waiting to resolve the Lightning Experience-enabled custom domain

message, I have found that the solution is the use the new cli commands that start with sf, rather than sfdx.

So the replacement command to open the org would be:

sf org open -o <org-alias>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .