2

Our Customer Portal (Experience) users are able to upload files to a case, yet they cannot view files uploaded to a case by an internal Salesforce user.

I have enabled the 'Let customer users access notes and attachments' checkbox in Setup > Digital Experience > Settings.

However, the Customer Portal (Experience) user is only able to upload files to the case, but not able to see the files uploaded to the case by (for example case owner).

Any advice would be greatly appreciated.

1 Answer 1

0

This is because the files owned by internal users are being marked as private.

You can read more about this via below article link

https://help.salesforce.com/s/articleView?id=sf.collab_files_make_private.htm&type=5

Also note that Files is a different than Notes and Attachments. So the settings that you have got is not going to work.

To view a file on a record, the user requires access to the record. The file visibility on the record must be set to allow site users.

The users can explicitly share access to the various users in such case using share button in the files page.

More on how File sharing and visibility works is shared in below documentation

https://help.salesforce.com/s/articleView?id=sf.networks_files_visibility_and_sharing.htm&type=5

4
  • sorry I meant attachments not files. The portal user can see the attachments section and any attachments they upload in that section, but not vise-a-versa.
    – PowerUp
    Commented Jan 19, 2022 at 5:27
  • @Powerup It's not advisable to use attachments any more. Use Files object for better security features. Commented Jan 19, 2022 at 8:44
  • Also could you check if the files feature is enabled or not? Because if this is enabled the Files go to Files records even when you upload to attachments Commented Jan 19, 2022 at 8:45
  • I would double check this setting for the org help.salesforce.com/s/articleView?id=000352010&type=1 Commented Jan 19, 2022 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .