4

NOTE: Update at bottom of post

I want to cache page resources in the application cache so that I can open a VisualForce page while offline.

I have specified the cache manifest in the <apex:page> as follows:

<apex:page doctype="html-5.0" manifest="/apex/manifestpage" showheader="false" sidebar="false" standardstylesheets="false" cache="false">

and the manifest itself as follows:

<apex:page contentType="text/cache-manifest" applyHtmlTag="false" standardStylesheets="false" showHeader="false">CACHE MANIFEST

/apex/MyPage

NETWORK:
*
</apex:page>

If the page is exposed and requested via a Force.com site, then the manifest is checked and all of the resources are downloaded.

However, if the page is opened as a standard VisualForce page, then there is an error after the applicationCache's checking event:

Application Cache Error event: Failed to parse manifest

The bottom line is that everything is working perfectly if the page is accessed by a force.com site, but not if accessed by as a stand-alone VF page which I need to do in order to access this page in a Salesforce1 app.

Can anybody give me a hint as to why this may be the case?

UPDATE:

I see that when the page is delivered as a stand-alone VF page, it is rendered in an iframe. Whereas, when exposed as a site, there is no iframe.

The outer html tag of the VF page has no manifest attribute, and it is the iframe's html tag that has the manifest attribute.

In addition, the safari browser gives a different error to the one specified above (which was shown by Chrome). We get:

[Error] Application Cache manifest could not be fetched, because a redirection was attempted.

1

The issue turned out to be the fact that the development mode was switched on, and this was interfering somehow. The footer obviously only shows when you are viewing the VF page in development mode and wouldn't be showing when accessing the page via the site.

Switched development mode off by going to:

Click on name -> My Settings -> Advanced User Settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.