1

I had a project added in Eclipse Force.com IDE, which was working fine.

Then I removed the project and added it back. This time I got a null pointer error:

enter image description here

Here's a paste of the logfile (from workspace/.metadata/.log:

http://pastebin.com/bvUgRax6

Googling, I see this problem has been around for several years.

I've tried rolling back to Java 6, which seems to be the most popular internet solution. This doesn't work. I've tried uninstalling everything Eclipse related, and reinstalling. This doesn't work.

ETA: Just tried rolling back to Java 6 update 27. Still no good.

NB The credentials work. The instance host is not reporting any issues on https://trust.salesforce.com/trust/status/

Using Eclipse Keplar on Windows 7.

0

This looks like an exception on the server side as it is fetching the components. T

  1. What version of the Force.com IDE are you using? Are you using hhttp://media.developerforce.com/force-ide/eclipse42? Also, how are you authenticating?
  2. Are you using username+password+token or using a session ID? This depends on what you entered on the dialog for creating a new project.
  3. When you reinstalled Eclipse, are you using the same workspace? What happens when you use a different workspace?
0

This has happened to me before. I hit continue at the point when you show abort or continue. After hitting continue it created an empty project. I right-clicked the project and told it to refresh. It then brought back all of the missing files.

Have you tried doing this?

  • Yes that doesn't work for me. See my answer above. – powlo May 22 '14 at 15:58
0

There was a VisualForce page returning an error when accessed ("An internal server error has occurred..." when navigating to its salesforce.com/apex/... url)

It is presumed that this page has become corrupted. It cannot be deleted.

Regarding Force.com IDE, the solution is to not download that particular page. Choose the manual selection option when setting up the project.

  • Glad you figured it out. When you say "cannot be deleted", you mean you cannot remove it through the Setup pages? – vazexqi May 22 '14 at 16:39
  • @vazexqi yes that's correct. – powlo May 22 '14 at 16:51
  • Could you file a support case with Salesforce? That will enable us to try to pinpoint the issue with your org and that page (maybe it has obsolete references to classes). – vazexqi May 22 '14 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.