0

I've created a public Restful web service via a Force.com Site as on this article, where on an Apex class I've exposed a HttpPost method which calls in the end the method: System.UserManagement.initSelfRegistration(), so people can self register through the public Site by providing their phone number.

But the issue is that when I try to test this via Postman it gives the error:

System.NoAccessException: Failed to get network info.

The Apex class I have declared as without sharing and on the Public Access Settings of the site I've defined for the Guest Profile the permissions:

  • API Enabled
  • Apex REST Services

but still the same error.

I've related also this question, where has happened the same error but it is in Apex test context. I did anyway as on the answer there but the error persisted

Has ANYONE encountered this issue before and how it can overcome?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.